ПРОДАЖИ
+7 (991) 312-04-37
trade@bestnet.ru
Авторизация

Логин:
Пароль:
Забыли свой пароль?
Регистрация
ВАШ ВОПРОС

Доступ к Личному кабинету закрыт!
Как получить доступ?


Форум

Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Выбрать дату в календареВыбрать дату в календаре

Страницы: Пред. 1 2 3 4 5 6 7 8 9
Источники данных
 
В БЭСТ-5 таких готовых источников сейчас нет.
Этот источник можно сделать на основе существующего источника по реесту документов(bdf.zapas_reestr.zapas_reestr_transfer), добавив в него поле NNOPER и затем в отчете сделать
"Запрос к БЭСТ" по таблице MAIN с выбором проводок по полю NNOPER.
Пытаюсь освоить Дизайнер отчетов
 
Цитата
Новосибирск ОАО "Электропромпроект" пишет:
А так можно сформировать к примеру Счет на оплату, тамгде его нет:
в Приложении Продажи-клиенты, заказы - продажи (счета) в Дизайнере отчетов открыть Счет на оплату . Затем сохранить его в файл. А далее загрузить его из файла
в Приложение Товары. Продукция./Учет движения товаров/Реализация со склада/Склад
Попытался, выдана ошибка :


Нет. Может быть в каком-то конкретном случае чисто случайно такое перетаскивание отчета и сработает, но вообщем так делать нельзя.
Во-первых в разных АРМах могут совершенно не совпадать поля из источника BDA.Task, которые потом в качестве параметров передаются в источники данных отчета. Во-вторых источники данных для отчета, как правило, пишутся в предположении, что данные надо выбирать из конкретных таблиц, конкретного АРМа, и автоматически перестроится на другие таблицы они не могут.
Кроме перетаскивания шаблона в таком случае придется "серьезно" править или даже полностью переписывать источники данных. Исключение здесь могут составлять только те отчеты у которых источники данных заранее писались в предположении, что эти отчеты будут вызываться из разных мест.
Пытаюсь освоить Дизайнер отчетов
 
Цитата
Новосибирск ОАО "Электропромпроект" пишет:
Тогда его (источник Val) можно удалить из Окна диалога (FPRM)? Вот я к чему веду/
Спасибо

Да. Насколько помню, в отчете этот источник больше нигде не используется, поэтому можно удалить.
Пытаюсь освоить Дизайнер отчетов
 
Цитата
Новосибирск ОАО "Электропромпроект" пишет:

8. Если не нужен Источник БЭСТ Справочника валют, то на каком этапе задается этот вариант задания маски.
Ведь если эту маску просто заменить, как сделали Вы, то получается, что она все равно задается на (или при) Источнике Справочник валют.

9. В документаци по ДизОтч есть такая фраза:
Далее с помощью двойного щелчка мыши в окне Form откроем редактор скрипта, выполняемого при активации формы. Активация формы вызывается всегда автоматически при формировании отчета.

Сейчас в окне Form определены 6 Источников БЭСТ. А задание формат связано толко с одним - Справочником валют.
Как двойной щелчок мыши привязывается именно к этому Источнику БЭСТ?
А если бы и в других источниках были определены подобные скрипты?


8. Еще раз, более конкретно:
Я предлагал заменить две строки
acc:=[DialogForm.Val."ТОЧНОСТЬ_ПРЕДСТАВЛЕНИЯ"];
Mask:='#,##0.'+Replicate(0,acc)+';; ';
на одну
mask:='#,#0.'+replicate('0',[GLOBAL('Curr_Accur')])+';; ';
В этом слечае функция GLOBAL('Curr_Accur') делает тоже самое, что и строка
acc:=[DialogForm.Val."ТОЧНОСТЬ_ПРЕДСТАВЛЕНИЯ"];
но отпадает необходимость обращения к источнику Val.
Только GLOBAL('Curr_Accur') всегда возвращает точность основной валюты.
Поэтому, если у Вас в документе могут быть суммы не в основной валюте, то такая замена конечно будет НЕ корректна.

9. Двойной щелчок мыши ни к какому источнику отношения не имеет, он просто открывает окно
"скрипта, выполняемого при активации формы". (Заметьте, именно активации ФОРМЫ, а НЕ источника). А в этом окне Вы пишите любые команды. В том числе можете обращаться к любым полям из любого источника.
Строка
acc := [DialogForm.Val."ТОЧНОСТЬ_ПРЕДСТАВЛЕНИЯ"];
Это и есть обращение к полю "ТОЧНОСТЬ_ПРЕДСТАВЛЕНИЯ" источника Val, и запись значения этого поля в переменную acc.
Пытаюсь освоить Дизайнер отчетов
 
Цитата
Новосибирск ОАО "Электропромпроект" пишет:
7. А не сможет она выскочить, если не пройдены (пропущены) какие-то этапы в форировании отчета? Я хотел потренироваться на задании формата чисел и попытался определить только одно поле в отчете - "Цена", и, соответственно, проделывал только то, что касается этого поля, пропустив все что делалось до этого в формировании отчета.


Очень маловероятно. Это в чистом виде ошибка самого источника данных (то есть фоксовой программы), а не отчета (в смысле той "картинки", которую Вы в дизайнере рисуете, включая задание форматов чисел). Если только Вы как-то некорректно изменили, передаваемые в источник параметры... Но тут уж надо опять шаблон смотреть.
Пытаюсь освоить Дизайнер отчетов
 
Цитата
Новосибирск ОАО "Электропромпроект" пишет:
Я думал, что его можно раскрыть программным средством (что-то типа редактора) и визульно просмотреть, как определны все параметры, что бы не проходить вновь все этапы настройки для выявления ошибки.


Дизайнер отчетов фактически и является визуальным редактором отчетов. Отчет сохраняется в "своем собственном" формате, поэтому редактировать его каким-то другим редактором не получится.
Пытаюсь освоить Дизайнер отчетов
 
Цитата
Новосибирск ОАО "Электропромпроект" пишет:
4. Что-то так и не предстает целостная картина формирования отчета. Какие-то незаконченные фрагменты.
К примеру, чем определяется количество Источников данных БЭСТ в формах диалога или вот фраза из документации Дизайнера отчетов:
Далее в свойстве «Params» Инспектора открываем окно параметров.
В окне несколько параметров. Для всех параметров в поле Значение, с помощью справочника указываем соответсвуюшее поле из источника Task
Я эту фразу воспринял как общую, за которй следует разъяснение, что это такое. Потому и был пропущен необходимый "кусок".
А в Вашей настройке этот пункт не для всех параметров в поле Значение , а выборочно.
Это чем определяется?

5.В Приложении Внешняя отчетность по F10 Вижу только алгоритм, а самого шаблона не вижу. Где находится шаблон и как к нему подключить Дизайнер отчетов?

6. - А где в Справочнике партнеров задется, что это свое предприятие. Что-то у себя я не нашел.


5. Количество источников определяется потребностями самого отчета. Для простейшего отчета с одной секцией MasterData может потребоваться всего один источник. Если секций MasterData несколько, или есть секции DetailData, то, как правило, на каждую такую секцию делается отдельный источник данных. Если же в отчете есть ещё карточка запроса параметров, с полями, которые выбираются из справочников, то для каждого такого справочнника тоже нужен свой источник данных. Часто в отчете требуется выводить название собственного предприятия, его адрес и другие атрибуты. В таком случае удобно (но не обязательно) использовать отдельный источник по справочнику партнеров с установленным параметром "признак_своего_предприятия".
Особое назначение имеет источник Task (имя может быть любое, важно, что свойство DSName = bda.task). Он предназначен для передачи параметров из текущего окна системы БЭСТ в отчет, а из отчета в источники данных.
Какие из полей источника Task будут передаваться в другие источники отчета - это определяет программист, разрабатывающий отчет. Если это форма документа, то обычно передаются поля, позволяющие однозначно идентифицировать этот документ (например, уникальный идентификатор документа), если это форма реестра, то, как правило, передаются сортировка и условие фильтрации, наложенные на реестр.
Для лучшего понимания работы попробуйте посмотреть исходные тексты на Visual FoxPro какого-нибудь источника для простейшего реестра или справочника.
5.В приложении "Внешняя отчетность->Генерация форм документов" по F10 входите в алгоритм, а потом жмите F10 ещё раз для расчета, и далее, что потребуется. После окончания расчета в дизайнере отчетов откроется форма документа.
6.Признак своего предприятия в справочнике партнеров - это галочка "Учетное предприятие" на первой закладке формы ввода в правом нижнем углу. В таблице partner.dbf это поле Is_Self = 1.
Пытаюсь освоить Дизайнер отчетов
 
Цитата
Новосибирск ОАО "Электропромпроект" пишет:
1.А с точностью предствления чиcел - Цена и Стоимость Вроде бы там с копейками сформировано
2.На очередной попытке сформировать отчет
стало выдавать сообщение об ошибке:
Error in line 60 User-interface operation not allowed at this time. 2031.
Отчего так?
3. А как просмотреть файлы .frf?


1. В отчете небольная ошибка при задании формата
Вместо
Mask:='#,##0'+Replicate(0,acc)+';; ';
надо
Mask:='#,##0.'+Replicate(0,acc)+';; ';
Обновил на FTP шаблон МН_32_2.frf.
Ниже строки
Mask:='#,##0.'+Replicate(0,acc)+';; ';
в комментариях написал другой вариант задания маски для сумм (одна строка вместо двух и не нужен источник для справочника валют).
2. Такая ошибка обычно возникает, если от фоксовой базы "отваливается" какая-то таблица. Попробуйте
выполнить индексацию базы с установленным влажком "Восстанавливать целостность БД".
3.Не совсем понял, что значит "как посмотреть"?
При сохранении шаблона отчета в файл .frf в дизайнере выполняется команда меню Файл->Сохранитиь в файл.
Командой Файл->Загрузить из файла шаблон отчета загружается обратно из .frf-файла в дизайнер.
А как Вы его ещё хотите посмотреть?
Пытаюсь освоить Дизайнер отчетов
 
1.Наименование документа задается в справочнике:
Товары.Продукция - Настройка, справочники - основная настройка - виды типовых документов
В Вашем случае для пункта "8.Реализация со склада" не задано название документа с кодом 001.
2.Документация не всегда поспевает за реальными изменениями в источниках данных. Очевидно поле
"Название_фирмы_из_карточки_предпр" было удалено из источника данных позже.
Для получения данных собственного предприятия рекомендую всегда использовать объект "источник данных БЭСТ"
со свойством DSName = bdf.sprav.sprav_partner. В параметре "признак_своего_предприятия" у этого источника
установите значение 1.
Адрес собственного предприятия тоже берите из этого объекта.
С учетом вышесказанного обновил на FTP шаблон МН_32_2.frf.
Пытаюсь освоить Дизайнер отчетов
 
Туда же на FTP выложил подправленный шаблон под именем МН_32_2.frf. Посмотрите задание параметров в источниках Shapka и Stroki. Сделал по аналогии с системным шаблоном "Накладная".
Пытаюсь освоить Дизайнер отчетов
 
Цитата
Новосибирск ОАО "Электропромпроект" пишет:
У меня для целей изучения создано несколько баз данных (несколько разных предприятий, у каждого своя база).
В одном из предприятияй я формирую отчет (с помощью Дизайнера отчетов).
А почему он виден и доступен в других предприятиях?


В БЭСТ-5 база отчетов одна общая на все предприятия. Отчеты хранятся не в той базе, в которой они создаются, а в серверном каталоге PRO.
Пытаюсь освоить Дизайнер отчетов
 
Цитата
Новосибирск ОАО "Электропромпроект" пишет:

Ну это же видно вот по этому файлу, что высота секции ReportTitle увеличена так, чтобы она полностью вмещает в себя поля:
"Поставщик", "Адрес поставщика", "Получатель" и "Адрес получателя".


По файлу видно, что секция PageHeader опущена вниз, а на секции ReportTitle полностью умещается только одно поле "ДАТА_ВЫПИСКИ". Остальные поля лежат на пустом месте. Увеличте у секции ReportTitle значение свойства Height, или мышкой её вниз растяните.
Пытаюсь освоить Дизайнер отчетов
 
Цитата
Новосибирск ОАО "Электропромпроект" пишет:

Сергей, Вы конечно извините меня, но мне нужно чуть подробнее сказать, что и где взять и куда выложить.
Вообще-то у меня пока конкретного какого-то шаблона нет.
Просто, я беру пример из докуметации по Дизайнеру отчетов и пытаюсь его сгенерировать у себя.


Вот этот самый пример, который Вы вставляете здесь в виде картинки JPG, сохраните в файл. В дизайнере отчетов меню
"Файл->Сохранить в файл". Имя давайте любое. Расширение у сохраненного файла будет FRF. Сохраненный FRF-файл (можно его заархивировать) попробуйте прикрепить здесь, или любым другим способом перешлите нам.
Пытаюсь освоить Дизайнер отчетов
 
Цитата
Новосибирск ОАО "Электропромпроект" пишет:
Вдогонку про кнопку Fx



Первый скрин 1 это тот, где не вижу кнопки. Видите, экран как бы не вмещается в окно. Как я не раздвигаю окно вправо и вниз, оно только увеличивается в размерах, а правая часть его такая же и остается. Это видно на втором скрине2.



А на скрине3 тоже видно что функциональные кнопки видны не до конца, и как бы я это окно не раздвигал, эти кнопки так до конца и не видны.

Вроде бы как внутренние парметры окна, больше внешних (не знаю как првильно это сказать)


Да, что-то у Вас непонятное с окнами происходит. Попробуйте удалить в системном реестре ветку
HKEY_CURRENT_USER\Software\FastReport\Best5
Там запоминаются параметры окон FastReport. После удаления, окна должны получить размеры "по-умолчанию".
Не уверен, но возможно это поможет.
Пытаюсь освоить Дизайнер отчетов
 
Данных в отчете может не быть из-за того, что к секции MasterData в параметре DataSouce не привязан источник данных.
Пытаюсь освоить Дизайнер отчетов
 
Выложите, пожалуйста, Ваш файл шаблона для формирования накладной в frf-формате, чтобы можно было более подробно его изучить.
По картинке могу лишь сказать, что высоту секции ReportTitle надо увеличить так, чтобы она полностью вмещала в себя поля:
"Поставщик", "Адрес поставщика", "Получатель" и "Адрес получателя".
Пытаюсь освоить Дизайнер отчетов
 
Если Вы установили флаг в параметре "Значение", то смотрите на само поле для ввода этого значения. В правом конце поля есть маленькая кнопочка, на которой написано "fx" (в том же самом месте, где в поле "Тип данных" располагается кнопка со стрелочкой вниз для открытия списка типов данных).
Изменение стандартных отчетов
 
Отчеты редактируются в самом БЭСТе дизайнером отчетов.
Запускается он из меню "Сервис->Дизайнер отчетов".
В дизайнере загружаете требуемый шаблон, редактируете и сохраняете под другим именем.
Хранятся отчеты в файле Server\Data\PRO\reptempl.dbf
Изменение стандартных отчетов
 
Стандартные отчеты изменять можно, но желательно после внесения изменений сохранять их под другим именем. Иначе после установки очередного пакета обновлений все Ваши изменения могут оказаться "затертыми" новой версией отчета, содержащейся в этом пакете.
Табуляция.
 
Из самого отчета "напрямую" в текстовый файл писать нельзя.
Можно попробовать сделать вывод непосредственно в фоксовом источнике функцией STRTOFILE().
Пробежаться по результирующему курсору и для каждой записи при помощи STRTOFILE() вывести в текстовый файл требуемую строку.
Табуляция.
 
Символ табуляции в объекте MemoView можно вставить функцией CHR(9), только желаемого эффекта это не даст, потому что объект MemoView не умеет обрабатывать этот символ. Он будет отображать его "квадратиком".
Как альтернативный вариант можно использовать в отчете объект RichView. В нем табуляция вставляется прямо с клавиатуры (и CHR(9) тоже работает).
Ещё для выравнивания значений в строке по правому краю можно применить функцию PADRIGHT(). Например:
PADRIGHT("Иванов",30," ")+PADRIGHT("Петр",20," ")+PADRIGHT("Сидорович",20," ")
Только в этом случае придется в отчете установить моноширинный шрифт.
Страницы: Пред. 1 2 3 4 5 6 7 8 9